# CVE-2026-31863: Improper Restriction of Excessive Authentication Attempts in github.com/anyproto/anytype-heart

> Attackers can bypass challenge-based authentication in the local gRPC API to access Anytype without the required 4-digit code.

- **Severity:** Low 3.6 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-vv3h-7qwr-722v, GO-2026-4680

## What is CVE-2026-31863?

CVE-2026-31863 is a low-severity authentication bypass vulnerability in anyproto anytype-cli, published on 11 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Anytype Heart is the middleware library for Anytype. The challenge-based authentication for the local gRPC client API can be bypassed, allowing an attacker to gain access without the 4-digit code. This vulnerability is fixed in anytype-heart 0.48.4, anytype-cli 0.1.11, and Anytype Desktop 0.54.5.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-31863?

6 open source packages ship an affected version, including github.com/anyproto/anytype-cli and github.com/anyproto/anytype-heart. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/anyproto/anytype-cli` | Go | All versions | 0.1.11 |
| `github.com/anyproto/anytype-cli` | Go | All versions | 0.1.11 |
| `github.com/anyproto/anytype-cli` | Go | All versions | 0.1.11 |
| `github.com/anyproto/anytype-heart` | Go | All versions | 0.48.4 |
| `github.com/anyproto/anytype-heart` | Go | All versions | 0.48.4 |
| `github.com/anyproto/anytype-heart` | Go | All versions | 0.48.4 |

Products: Anytype Anytype Cli, Anytype Anytype Desktop, Anytype Anytype Heart.

## How do I fix CVE-2026-31863?

Upgrade github.com/anyproto/anytype-cli to 0.1.11 or later.

## Is CVE-2026-31863 being exploited?

There is no known exploitation of CVE-2026-31863 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31863 and fix it if it is affected.

What it is: CVE-2026-31863 is a low-severity authentication bypass vulnerability in anyproto anytype-cli, published on 11 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31863 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/anyproto/anytype-cli (Go): affected all versions; fixed in 0.1.11
- github.com/anyproto/anytype-cli (Go): affected all versions; fixed in 0.1.11
- github.com/anyproto/anytype-cli (Go): affected all versions; fixed in 0.1.11
- github.com/anyproto/anytype-heart (Go): affected all versions; fixed in 0.48.4
- github.com/anyproto/anytype-heart (Go): affected all versions; fixed in 0.48.4
- github.com/anyproto/anytype-heart (Go): affected all versions; fixed in 0.48.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31863/ (Markdown: https://insights.sbomify.com/CVE-2026-31863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31863
- OSV: https://osv.dev/vulnerability/CVE-2026-31863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31863/
Summaries are generated and may contain mistakes; the official description above is the record.
