# CVE-2026-31865: Elysia Cookie Value Prototype Pollution

> Prototype pollution in Elysia cookie handling allows attackers to override properties, potentially leading to code execution or security bypasses.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-8hq9-phh3-p2wp

## What is CVE-2026-31865?

CVE-2026-31865 is a medium-severity vulnerability in elysiajs elysia, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation, and client-server communication. Prior to version 1.4.27, an Elysia cookie can be overridden by prototype pollution , eg. `__proto__`. This issue is patched in 1.4.27. As a workaround, use t.Cookie validation to enforce validation value and/or prevent iterable over cookie if possible.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-31865?

2 open source packages ship an affected version, including elysia. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elysia` | npm | All versions | 1.4.27 |
| `elysia` | npm | All versions | 1.4.27 |

Products: Elysiajs Elysia.

## How do I fix CVE-2026-31865?

Upgrade elysia to 1.4.27 or later.

## Is CVE-2026-31865 being exploited?

There is no known exploitation of CVE-2026-31865 in the wild and no public exploit code.

## Other vulnerabilities in elysiajs elysia

- [CVE-2025-66456](https://insights.sbomify.com/CVE-2025-66456/): Elysia vulnerable to prototype pollution with multiple standalone schema validation (critical 9.1)
- [CVE-2026-30837](https://insights.sbomify.com/CVE-2026-30837/): Elysia has a string URL format redos (high 7.5)
- [CVE-2025-66457](https://insights.sbomify.com/CVE-2025-66457/): Elysia affected by arbitrary code injection through cookie config (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31865 and fix it if it is affected.

What it is: CVE-2026-31865 is a medium-severity vulnerability in elysiajs elysia, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31865 in the wild and no public exploit code.

Affected packages and fixed versions:
- elysia (npm): affected all versions; fixed in 1.4.27
- elysia (npm): affected all versions; fixed in 1.4.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31865/ (Markdown: https://insights.sbomify.com/CVE-2026-31865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31865
- OSV: https://osv.dev/vulnerability/CVE-2026-31865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31865/
Summaries are generated and may contain mistakes; the official description above is the record.
