# CVE-2026-31867: Craft Commerce has a Potential IDOR in Commerce carts

> Attackers can hijack shopping carts and access PII by guessing cart IDs due to missing ownership validation in Craft Commerce.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-vff3-pqq8-4cpq

## What is CVE-2026-31867?

CVE-2026-31867 is a medium-severity missing authorization vulnerability in craftcms commerce, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.11.0 and 5.6.0, An Insecure Direct Object Reference (IDOR) vulnerability exists in Craft Commerce’s cart functionality that allows users to hijack any shopping cart by knowing or guessing its 32-character number. The CartController accepts a user-supplied number parameter to load and modify shopping carts. No ownership validation is performed - the code only checks if the order exists and is incomplete, not whether the requester has authorization to access it. This vulnerability enables the takeover of shopping sessions and potential exposure of PII. This vulnerability is fixed in 4.11.0 and 5.6.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-31867?

4 open source packages ship an affected version, including craftcms/commerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/commerce` | Packagist | From 4.0.0 | 4.11.0 |
| `craftcms/commerce` | Packagist | From 4.0.0 | 4.11.0 |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.6.0 |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.6.0 |

Products: Craftcms Craft Commerce.

## How do I fix CVE-2026-31867?

Upgrade craftcms/commerce to a fixed version for your release line: 4.11.0 or 5.6.0.

## Is CVE-2026-31867 being exploited?

There is no known exploitation of CVE-2026-31867 in the wild and no public exploit code.

## Other vulnerabilities in craftcms commerce

- [CVE-2026-29172](https://insights.sbomify.com/CVE-2026-29172/): Craft Commerce has a SQL Injection in Commerce Purchasables Table Sorting (high 8.7)
- [CVE-2026-29174](https://insights.sbomify.com/CVE-2026-29174/): Craft Commerce has a SQL Injection in Commerce Inventory Table Sorting (high 8.7)
- [CVE-2026-29175](https://insights.sbomify.com/CVE-2026-29175/): Multiple Stored XSS in Commerce Inventory Page Leading to Session Hijacking (high 8.6)
- [CVE-2026-25482](https://insights.sbomify.com/CVE-2026-25482/): Craft Commerce has Stored DOM XSS in Order Status Name (Reflects in "Recent Orders" Dashboard Widget) (medium 6.2)
- [CVE-2026-25483](https://insights.sbomify.com/CVE-2026-25483/): Craft Commerce has Stored XSS via Order Status Message with potential database exfiltration (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31867 and fix it if it is affected.

What it is: CVE-2026-31867 is a medium-severity missing authorization vulnerability in craftcms commerce, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31867 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/commerce (Packagist): affected from 4.0.0; fixed in 4.11.0
- craftcms/commerce (Packagist): affected from 4.0.0; fixed in 4.11.0
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.6.0
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31867/ (Markdown: https://insights.sbomify.com/CVE-2026-31867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31867
- OSV: https://osv.dev/vulnerability/CVE-2026-31867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31867/
Summaries are generated and may contain mistakes; the official description above is the record.
