CVE-2026-31868 Parse Server has Stored XSS via file upload of HTML-renderable file types

Medium 6.3 Published Updated

Attackers can upload malicious SVG or XML files to execute JavaScript in victims' browsers, stealing session tokens or performing actions on their behalf.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-31868?

CVE-2026-31868 is a medium-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.4 and 8.6.30, an attacker can upload a file with a file extension or content type that is not blocked by the default configuration of the Parse Server fileUpload.fileExtensions option. The file can contain malicious code, for example JavaScript in an SVG or XHTML file. When the file is accessed via its URL, the browser renders the file and executes the malicious code in the context of the Parse Server domain. This is a stored Cross-Site Scripting (XSS) vulnerability that can be exploited to steal session tokens, redirect users, or perform actions on behalf of other users. Affected file extensions and content types include .svgz, .xht, .xml, .xsl, .xslt, and content types application/xhtml+xml and application/xslt+xml for extensionless uploads. Uploading of .html, .htm, .shtml, .xhtml, and .svg files was already blocked. This vulnerability is fixed in 9.6.0-alpha.4 and 8.6.30.

Weakness: CWE-79

Which versions are affected by CVE-2026-31868?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions8.6.30
parse-server npmAll versions8.6.30
parse-server npmFrom 9.0.0-alpha.19.6.0-alpha.4
parse-server npmFrom 9.0.0-alpha.19.6.0-alpha.4
parse BitnamiAll versions8.6.30, 9.6.0

Products include Parseplatform Parse-Server.

How do I fix CVE-2026-31868?

Upgrade parse-server to a fixed version for your release line: 8.6.30 or 9.6.0-alpha.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-31868 being exploited?

There is no known exploitation of CVE-2026-31868 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2026-31868, GHSA-v5hf-f4c3-m5rv.

Is CVE-2026-31868 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free