# CVE-2026-31869: Discourse: Composer mentions endpoint leaks hidden group membership through PM `allowed_names` check

> Authenticated attackers can infer hidden group membership in Discourse by probing the mentions endpoint, bypassing visibility controls.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** BIT-discourse-2026-31869, GHSA-5f9h-vp7v-7vq5

## What is CVE-2026-31869?

CVE-2026-31869 is a medium-severity vulnerability in Discourse Discourse, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, the ComposerController#mentions endpoint reveals hidden group membership to any authenticated user who can message the group. By supplying allowed_names referencing a hidden-membership group and probing arbitrary usernames, an attacker can infer membership based on whether user_reasons returns "private" for a given user. This bypasses group member-visibility controls. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. To work around this issue, restrict the messageable policy of any hidden-membership group to staff or group members only, so untrusted users cannot reach the vulnerable code path.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-31869?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | From 2026.1.0 | 2026.1.2, 2026.2.1, 2026.3.0 |

Products: Discourse Discourse.

## How do I fix CVE-2026-31869?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.

## Is CVE-2026-31869 being exploited?

There is no known exploitation of CVE-2026-31869 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31869 and fix it if it is affected.

What it is: CVE-2026-31869 is a medium-severity vulnerability in Discourse Discourse, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31869 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected from 2026.1.0; fixed in 2026.1.2, 2026.2.1, 2026.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31869/ (Markdown: https://insights.sbomify.com/CVE-2026-31869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31869
- OSV: https://osv.dev/vulnerability/CVE-2026-31869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31869/
Summaries are generated and may contain mistakes; the official description above is the record.
