# CVE-2026-31887: Shopware unauthenticated data extraction possible through store-api.order endpoint

> Unauthenticated attackers can access other customers' orders via the store-api.order endpoint due to insufficient filter checks.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-7vvp-j573-5584

## What is CVE-2026-31887?

CVE-2026-31887 is a high-severity missing authorization vulnerability in Shopware Shopware, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopware is an open commerce platform. Prior to 6.7.8.1 and 6.6.10.15, an insufficient check on the filter types for unauthenticated customers allows access to orders of other customers. This is part of the deepLinkCode support on the store-api.order endpoint. This vulnerability is fixed in 6.7.8.1 and 6.6.10.15.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-31887?

8 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.6.10.15 |
| `shopware/core` | Packagist | All versions | 6.6.10.15 |
| `shopware/core` | Packagist | From 6.7.0.0 | 6.7.8.1 |
| `shopware/core` | Packagist | From 6.7.0.0 | 6.7.8.1 |
| `shopware/platform` | Packagist | All versions | 6.6.10.15 |
| `shopware/platform` | Packagist | All versions | 6.6.10.15 |
| `shopware/platform` | Packagist | From 6.7.0.0 | 6.7.8.1 |
| `shopware/platform` | Packagist | From 6.7.0.0 | 6.7.8.1 |

Products: Shopware Shopware.

## How do I fix CVE-2026-31887?

Upgrade shopware/core to a fixed version for your release line: 6.6.10.15 or 6.7.8.1.

## Is CVE-2026-31887 being exploited?

There is no known exploitation of CVE-2026-31887 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31889](https://insights.sbomify.com/CVE-2026-31889/): Shopware has a potential take over of app credentials (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31887 and fix it if it is affected.

What it is: CVE-2026-31887 is a high-severity missing authorization vulnerability in Shopware Shopware, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31887 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.6.10.15
- shopware/core (Packagist): affected all versions; fixed in 6.6.10.15
- shopware/core (Packagist): affected from 6.7.0.0; fixed in 6.7.8.1
- shopware/core (Packagist): affected from 6.7.0.0; fixed in 6.7.8.1
- shopware/platform (Packagist): affected all versions; fixed in 6.6.10.15
- shopware/platform (Packagist): affected all versions; fixed in 6.6.10.15
- shopware/platform (Packagist): affected from 6.7.0.0; fixed in 6.7.8.1
- shopware/platform (Packagist): affected from 6.7.0.0; fixed in 6.7.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31887/ (Markdown: https://insights.sbomify.com/CVE-2026-31887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31887
- OSV: https://osv.dev/vulnerability/CVE-2026-31887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31887/
Summaries are generated and may contain mistakes; the official description above is the record.
