CVE-2026-31890 Inspektor Gadget: Tracing Denial of Service via Event Flooding

Medium 4.8 Published Updated

A malicious container can flood the ring-buffer to cause a Denial of Service by forcing the system to drop events from other containers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-31890?

CVE-2026-31890 is a medium-severity denial of service vulnerability in inspektor-gadget, published on 12 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Inspektor Gadget is a set of tools and framework for data collection and system inspection on Kubernetes clusters and Linux hosts using eBPF. Prior to 0.50.1, in a situation where the ring-buffer of a gadget is – incidentally or maliciously – already full, the gadget will silently drop events. The include/gadget/buffer.h file contains definitions for the Buffer API that gadgets can use to, among the other things, transfer data from eBPF programs to userspace. For hosts running a modern enough Linux kernel (>= 5.8), this transfer mechanism is based on ring-buffers. The size of the ring-buffer for the gadgets is hard-coded to 256KB. When a gadget_reserve_buf fails because of insufficient space, the gadget silently cleans up without producing an alert. The lost count reported by the eBPF operator, when using ring-buffers – the modern choice – is hardcoded to zero. The vulnerability can be used by a malicious event source (e.g. a compromised container) to cause a Denial Of Service, forcing the system to drop events coming from other containers (or the same container). This vulnerability is fixed in 0.50.1.

Weakness: CWE-770, CWE-223

Which versions are affected by CVE-2026-31890?

It affects 1 product.

Products include Linuxfoundation Inspektor Gadget.

How do I fix CVE-2026-31890?

No fix has been published for CVE-2026-31890 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-31890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31890 exists.

Sources

Also known as GHSA-wv52-frfv-mfh4.

Is CVE-2026-31890 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free