CVE-2026-31891 Cockpit CMS has SQL Injection in MongoLite Aggregation Optimizer via toJsonExtractRaw()
Attackers with read-only API keys can inject SQL to bypass content filters and extract unauthorized data from the database.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31891?
CVE-2026-31891 is a high-severity SQL injection vulnerability in Cockpit-HQ Cockpit, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Cockpit is a headless content management system. Any Cockpit CMS instance running version 2.13.4 or earlier with API access enabled is potentially affected by a a SQL Injection vulnerability in the MongoLite Aggregation Optimizer. Any deployment where the `/api/content/aggregate/{model}` endpoint is publicly accessible or reachable by untrusted users may be vulnerable, and attackers in possession of a valid read-only API key (the lowest privilege level) can exploit this vulnerability — no admin access is required. An attacker can inject arbitrary SQL via unsanitized field names in aggregation queries, bypass the `_state=1` published-content filter to access unpublished or restricted content, and extract unauthorized data from the underlying SQLite content database. This vulnerability has been patched in version 2.13.5. The fix applies the same field-name sanitization introduced in v2.13.3 for `toJsonPath()` to the `toJsonExtractRaw()` method in `lib/MongoLite/Aggregation/Optimizer.php`, closing the injection vector in the Aggregation Optimizer.
Weakness: CWE-89
Which versions are affected by CVE-2026-31891?
2 open source packages ship an affected version, including cockpit-hq/cockpit. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cockpit-hq/cockpit Packagist | All versions | 2.13.5 |
cockpit-hq/cockpit Packagist | All versions | 2.13.5 |
Products include Agentejo Cockpit.
How do I fix CVE-2026-31891?
Upgrade cockpit-hq/cockpit to 2.13.5 or later.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-31891 being exploited?
There is no known exploitation of CVE-2026-31891 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Cockpit-HQ Cockpit
- CVE-2023-4195 PHP Remote File Inclusion in cockpit-hq/cockpit
- CVE-2024-4825 Unrestricted Upload of File with Dangerous Type vulnerability on Cockpit CMS from Agentejo
- CVE-2022-2818 Improper Removal of Sensitive Information Before Storage or Transfer in cockpit-hq/cockpit
- CVE-2020-35131 Code injection in n/a
- CVE-2020-35846 SQL injection in n/a
Sources
Also known as GHSA-7x5c-vfhj-9628, UBUNTU-CVE-2026-31891.