# CVE-2026-31891: Cockpit CMS has SQL Injection in MongoLite Aggregation Optimizer via toJsonExtractRaw()

> Attackers with read-only API keys can inject SQL to bypass content filters and extract unauthorized data from the database.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-7x5c-vfhj-9628, UBUNTU-CVE-2026-31891

## What is CVE-2026-31891?

CVE-2026-31891 is a high-severity SQL injection vulnerability in Cockpit-HQ Cockpit, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cockpit is a headless content management system. Any Cockpit CMS instance running version 2.13.4 or earlier with API access enabled is potentially affected by a a SQL Injection vulnerability in the MongoLite Aggregation Optimizer. Any deployment where the `/api/content/aggregate/{model}` endpoint is publicly accessible or reachable by untrusted users may be vulnerable, and attackers in possession of a valid read-only API key (the lowest privilege level) can exploit this vulnerability — no admin access is required. An attacker can inject arbitrary SQL via unsanitized field names in aggregation queries, bypass the `_state=1` published-content filter to access unpublished or restricted content, and extract unauthorized data from the underlying SQLite content database. This vulnerability has been patched in version 2.13.5. The fix applies the same field-name sanitization introduced in v2.13.3 for `toJsonPath()` to the `toJsonExtractRaw()` method in `lib/MongoLite/Aggregation/Optimizer.php`, closing the injection vector in the Aggregation Optimizer.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-31891?

2 open source packages ship an affected version, including cockpit-hq/cockpit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.13.5 |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.13.5 |

Products: Agentejo Cockpit.

## How do I fix CVE-2026-31891?

Upgrade cockpit-hq/cockpit to 2.13.5 or later.

## Is CVE-2026-31891 being exploited?

There is no known exploitation of CVE-2026-31891 in the wild and no public exploit code.

Public exploit code:

- SQL Injection in MongoLite Aggregation Optimizer via toJsonExtractRaw() (github_poc): https://github.com/ffasterss/CVE-2026-31891

## Other vulnerabilities in Cockpit-HQ Cockpit

- [CVE-2023-4195](https://insights.sbomify.com/CVE-2023-4195/): PHP Remote File Inclusion in cockpit-hq/cockpit (critical 9.9)
- [CVE-2024-4825](https://insights.sbomify.com/CVE-2024-4825/): Unrestricted Upload of File with Dangerous Type vulnerability on Cockpit CMS from Agentejo (critical 9.8)
- [CVE-2022-2818](https://insights.sbomify.com/CVE-2022-2818/): Improper Removal of Sensitive Information Before Storage or Transfer in cockpit-hq/cockpit (critical 9.8)
- [CVE-2020-35131](https://insights.sbomify.com/CVE-2020-35131/): Code injection in n/a (critical 9.8)
- [CVE-2020-35846](https://insights.sbomify.com/CVE-2020-35846/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31891 and fix it if it is affected.

What it is: CVE-2026-31891 is a high-severity SQL injection vulnerability in Cockpit-HQ Cockpit, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31891 in the wild and no public exploit code.

Affected packages and fixed versions:
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.13.5
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.13.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31891/ (Markdown: https://insights.sbomify.com/CVE-2026-31891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31891
- OSV: https://osv.dev/vulnerability/CVE-2026-31891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31891/
Summaries are generated and may contain mistakes; the official description above is the record.
