CVE-2026-31901 Parse Server has user enumeration via email verification endpoint
Attackers can enumerate registered users by observing distinct error responses from the email verification endpoint in Parse Server deployments with email verification enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31901?
CVE-2026-31901 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.34 and 9.6.0-alpha.8, the email verification endpoint (/verificationEmailRequest) returns distinct error responses depending on whether an email address belongs to an existing user, is already verified, or does not exist. An attacker can send requests with different email addresses and observe the error codes to determine which email addresses are registered in the application. This is a user enumeration vulnerability that affects any Parse Server deployment with email verification enabled (verifyUserEmails: true). This vulnerability is fixed in 8.6.34 and 9.6.0-alpha.8.
Weakness: CWE-204
Which versions are affected by CVE-2026-31901?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.34 |
parse-server npm | All versions | 8.6.34 |
parse-server npm | From 9.0.0-alpha.1 | 9.6.0-alpha.8 |
parse-server npm | From 9.0.0-alpha.1 | 9.6.0-alpha.8 |
parse Bitnami | All versions | 8.6.34, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-31901?
Upgrade parse-server to a fixed version for your release line: 8.6.34 or 9.6.0-alpha.8.
Is CVE-2026-31901 being exploited?
There is no known exploitation of CVE-2026-31901 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-31901, GHSA-w54v-hf9p-8856.