CVE-2026-31908 Apache APISIX: forward auth plugin allows header injection
Attackers can inject malicious headers via the forward-auth plugin in Apache APISIX, potentially bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31908?
CVE-2026-31908 is a critical vulnerability in Apache APISIX, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Header injection vulnerability in Apache APISIX.
The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0.
Users are recommended to upgrade to version 3.16.0, which fixes the issue.
Weakness: CWE-75
Which versions are affected by CVE-2026-31908?
1 open source package ship an affected version, including apisix. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 2.12.0 | 3.16.0 |
Products include Apache Apisix.
How do I fix CVE-2026-31908?
Upgrade apisix to 3.16.0 or later.
Is CVE-2026-31908 being exploited?
There is no known exploitation of CVE-2026-31908 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache APISIX
- CVE-2022-24112 Apache APISIX Authentication Bypass
- CVE-2022-25757 Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS
- CVE-2025-27446 Privilege escalation in Apache APISIX Java Plugin Runner
- CVE-2026-31923 Apache APISIX: Openid-connect `tls_verify` field is disabled by default
Sources
Also known as BIT-apisix-2026-31908, GHSA-jv22-34xc-w9x6.