{"answers":{"affected":"1 open source package ship an affected version, including apisix. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-31908 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.16.0 or later.","what":"CVE-2026-31908 is a critical vulnerability in Apache APISIX, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-31908 and fix it if it is affected.\n\nWhat it is: CVE-2026-31908 is a critical vulnerability in Apache APISIX, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-31908 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 2.12.0; fixed in 3.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-31908/ (Markdown: https://insights.sbomify.com/CVE-2026-31908/index.md)","id":"CVE-2026-31908","markdown":"https://insights.sbomify.com/CVE-2026-31908/index.md","name":"CVE-2026-31908","record":{"aliases":["BIT-apisix-2026-31908","GHSA-jv22-34xc-w9x6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"API Gateway","requires_auth":"none","summary":"Attackers can inject malicious headers via the forward-auth plugin in Apache APISIX, potentially bypassing security controls.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apisix","vendor":"apache"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-75","name":"Failure to Sanitize Special Elements into a Different Plane"}],"description":"Header injection vulnerability in Apache APISIX.\n\nThe attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers.\nThis issue affects Apache APISIX: from 2.12.0 through 3.15.0.\n\nUsers are recommended to upgrade to version 3.16.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-04-19","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-04-19T17:24:09Z","kind":"github_poc","ref":"https://github.com/MehranTurk/CVE-2026-31908","stars":1,"title":"This proof-of-concept (PoC) exploit targets CVE-2026-31908, a critical header injection vulnerability affecting Apache APISIX versions 2.12.0 through 3.15.0"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache APISIX: forward auth plugin allows header injection","id":"CVE-2026-31908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Apache OFBiz: Unauthenticated Shipment Label Image Disclosure","id":"CVE-2026-31909"},"packages":[{"ecosystem":"Bitnami","fixed":["3.16.0"],"introduced":["2.12.0"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-31908"}],"prev":{"headline":"Apache OFBiz: Reflected XSS via Improper HTML Attribute Escaping in Layered-Modal Dialog Parameters","id":"CVE-2026-31906"},"products":["Apache APISIX"],"published":"2026-04-14","related":[{"cvss_score":9.8,"headline":"Apache APISIX Authentication Bypass","id":"CVE-2022-24112","kev_date_added":"2022-08-25","published":"2022-02-11"},{"cvss_score":9.8,"headline":"Apache APISIX: the body_schema check in request-validation plugin can be bypassed","id":"CVE-2022-25757","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":8.7,"headline":"Apache APISIX: Unauthenticated CPU-exhaustion DoS","id":"CVE-2026-75005","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":7.8,"headline":"Privilege escalation in Apache APISIX Java Plugin Runner","id":"CVE-2025-27446","kev_date_added":null,"published":"2025-07-06"},{"cvss_score":7.5,"headline":"Apache APISIX: Openid-connect `tls_verify` field is disabled by default","id":"CVE-2026-31923","kev_date_added":null,"published":"2026-04-14"},{"cvss_score":7.5,"headline":"Apache APISIX: basic-auth logs plaintext credentials at info level","id":"CVE-2025-62232","kev_date_added":null,"published":"2025-10-31"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can inject malicious headers via the forward-auth plugin in Apache APISIX, potentially bypassing security controls.","url":"https://insights.sbomify.com/CVE-2026-31908/"}