# CVE-2026-31908: Apache APISIX: forward auth plugin allows header injection

> Attackers can inject malicious headers via the forward-auth plugin in Apache APISIX, potentially bypassing security controls.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** BIT-apisix-2026-31908, GHSA-jv22-34xc-w9x6

## What is CVE-2026-31908?

CVE-2026-31908 is a critical vulnerability in Apache APISIX, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Header injection vulnerability in Apache APISIX.

The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers.
This issue affects Apache APISIX: from 2.12.0 through 3.15.0.

Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Weakness: CWE-75 (Failure to Sanitize Special Elements into a Different Plane)

## Which versions are affected by CVE-2026-31908?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 2.12.0 | 3.16.0 |

Products: Apache Apisix.

## How do I fix CVE-2026-31908?

Upgrade apisix to 3.16.0 or later.

## Is CVE-2026-31908 being exploited?

There is no known exploitation of CVE-2026-31908 in the wild and no public exploit code.

Public exploit code:

- This proof-of-concept (PoC) exploit targets CVE-2026-31908, a critical header injection vulnerability affecting Apache APISIX versions 2.12.0 through 3.15.0 (github_poc): https://github.com/MehranTurk/CVE-2026-31908

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)
- [CVE-2026-31923](https://insights.sbomify.com/CVE-2026-31923/): Apache APISIX: Openid-connect `tls_verify` field is disabled by default (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31908 and fix it if it is affected.

What it is: CVE-2026-31908 is a critical vulnerability in Apache APISIX, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31908 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 2.12.0; fixed in 3.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31908/ (Markdown: https://insights.sbomify.com/CVE-2026-31908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31908
- OSV: https://osv.dev/vulnerability/CVE-2026-31908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31908/
Summaries are generated and may contain mistakes; the official description above is the record.
