CVE-2026-31923 Apache APISIX: Openid-connect `tls_verify` field is disabled by default
Apache APISIX openid-connect plugin defaults to disabling TLS verification, allowing attackers to intercept sensitive data via man-in-the-middle attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31923?
CVE-2026-31923 is a high-severity vulnerability in Apache APISIX, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX.
This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0.
Users are recommended to upgrade to version 3.16.0, which fixes the issue.
Weakness: CWE-319
Which versions are affected by CVE-2026-31923?
1 open source package ship an affected version, including apisix. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 0.7.0 | 3.16.0 |
Products include Apache Apisix.
How do I fix CVE-2026-31923?
Upgrade apisix to 3.16.0 or later.
Is CVE-2026-31923 being exploited?
There is no known exploitation of CVE-2026-31923 in the wild and no public exploit code.
Other vulnerabilities in Apache APISIX
- CVE-2022-24112 Apache APISIX Authentication Bypass
- CVE-2022-25757 Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- CVE-2026-31908 Apache APISIX: forward auth plugin allows header injection
- CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS
- CVE-2025-27446 Privilege escalation in Apache APISIX Java Plugin Runner
Sources
Also known as BIT-apisix-2026-31923, GHSA-j648-xxf5-44cv.