# CVE-2026-31937: Suricata dcerpc: quadratic complexity in dcerpc buffering

> Attackers can cause performance degradation in Suricata via inefficient DCERPC buffering, requiring an upgrade to mitigate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-31937, GHSA-86vg-w8vm-m3gg, UBUNTU-CVE-2026-31937

## What is CVE-2026-31937?

CVE-2026-31937 is a high-severity denial of service vulnerability in Oisf Suricata, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Suricata is a network IDS, IPS and NSM engine. Prior to version 7.0.15, inefficiency in DCERPC buffering can lead to a performance degradation. This issue has been patched in version 7.0.15.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-31937?

It affects 1 product.


Products: Oisf Suricata.

## How do I fix CVE-2026-31937?

Upgrade to a fixed version.

## Is CVE-2026-31937 being exploited?

There is no known exploitation of CVE-2026-31937 in the wild and no public exploit code.

## Other vulnerabilities in Oisf Suricata

- [CVE-2023-35853](https://insights.sbomify.com/CVE-2023-35853/): Code injection in n/a (critical 9.8)
- [CVE-2021-37592](https://insights.sbomify.com/CVE-2021-37592/): Other in n/a (critical 9.8)
- [CVE-2018-10244](https://insights.sbomify.com/CVE-2018-10244/): Integer overflow in n/a (critical 9.8)
- [CVE-2026-94083](https://insights.sbomify.com/CVE-2026-94083/): Memory corruption in Suricata (critical 9.4)
- [CVE-2026-94084](https://insights.sbomify.com/CVE-2026-94084/): Use after free in Suricata (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31937 and fix it if it is affected.

What it is: CVE-2026-31937 is a high-severity denial of service vulnerability in Oisf Suricata, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31937 in the wild and no public exploit code.

Affected product: Oisf Suricata. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31937/ (Markdown: https://insights.sbomify.com/CVE-2026-31937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31937
- OSV: https://osv.dev/vulnerability/CVE-2026-31937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31937/
Summaries are generated and may contain mistakes; the official description above is the record.
