# CVE-2026-31938: jsPDF has HTML Injection in New Window paths

> Attackers can inject arbitrary HTML and scripts into the browser context when victims open PDFs generated with unsanitized user-controlled options in jsPDF.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 7 Sep 2026
- **Also known as:** GHSA-wfv2-pwc8-crg5, MINI-5gq5-pj24-hvr5, MINI-x4vw-cvcr-33xf, MINI-x5fr-xr8g-f6vp, ROOT-APP-NPM-CVE-2026-31938

## What is CVE-2026-31938?

CVE-2026-31938 is a critical cross-site scripting vulnerability in parallax jsPDF, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

jsPDF is a library to generate PDFs in JavaScript. Prior to version 4.2.1, user control of the `options` argument of the `output` function allows attackers to inject arbitrary HTML (such as scripts) into the browser context the created PDF is opened in. The vulnerability can be exploited in the following scenario: the attacker provides values for the output options, for example via a web interface. These values are then passed unsanitized (automatically or semi-automatically) to the attack victim. The victim creates and opens a PDF with the attack vector using one of the vulnerable method overloads inside their browser. The attacker can thus inject scripts that run in the victims browser context and can extract or modify secrets from this context. The vulnerability has been fixed in jspdf@4.2.1. As a workaround, sanitize user input before passing it to the output method.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-31938?

2 open source packages ship an affected version, including jspdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jspdf` | npm | All versions | 4.2.1 |
| `jspdf` | npm | All versions | 4.2.1 |

Products: Parall Jspdf.

## How do I fix CVE-2026-31938?

Upgrade jspdf to 4.2.1 or later.

## Is CVE-2026-31938 being exploited?

There is no known exploitation of CVE-2026-31938 in the wild and no public exploit code.

## Other vulnerabilities in parallax jsPDF

- [CVE-2025-68428](https://insights.sbomify.com/CVE-2025-68428/): jsPDF has Local File Inclusion/Path Traversal vulnerability (critical 9.2)
- [CVE-2026-25535](https://insights.sbomify.com/CVE-2026-25535/): jsPDF Affected by Client-Side/Server-Side Denial of Service via Malicious GIF Dimensions (high 8.7)
- [CVE-2026-24133](https://insights.sbomify.com/CVE-2026-24133/): jsPDF Affected by Denial of Service (DoS) via Unvalidated BMP Dimensions in BMPDecoder (high 8.7)
- [CVE-2025-57810](https://insights.sbomify.com/CVE-2025-57810/): jsPDF Parsing of Corrupt PNGs Leads to Potential Denial of Service (DoS) (high 8.7)
- [CVE-2025-29907](https://insights.sbomify.com/CVE-2025-29907/): jsPDF Bypass Regular Expression Denial of Service (ReDoS) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31938 and fix it if it is affected.

What it is: CVE-2026-31938 is a critical cross-site scripting vulnerability in parallax jsPDF, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-31938 in the wild and no public exploit code.

Affected packages and fixed versions:
- jspdf (npm): affected all versions; fixed in 4.2.1
- jspdf (npm): affected all versions; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31938/ (Markdown: https://insights.sbomify.com/CVE-2026-31938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31938
- OSV: https://osv.dev/vulnerability/CVE-2026-31938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31938/
Summaries are generated and may contain mistakes; the official description above is the record.
