# CVE-2026-31959: SSRF in Quill via unvalidated URL from Apple notarization log retrieval

> An attacker with TLS interception capabilities can force Quill to fetch arbitrary URLs, potentially exposing internal network data or cloud credentials.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-7q3q-5px6-4c5p, GO-2026-4671

## What is CVE-2026-31959?

CVE-2026-31959 is a medium-severity server-side request forgery vulnerability in anchore quill, published on 11 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Quill provides simple mac binary signing and notarization from any platform. Quill before version v0.7.1 contains a Server-Side Request Forgery (SSRF) vulnerability when attempting to fetch the Apple notarization submission logs. Exploitation requires the ability to modify API responses from Apple's notarization service, which is not possible under standard network conditions due to HTTPS with proper TLS certificate validation; however, environments with TLS-intercepting proxies (common in corporate networks), compromised certificate authorities, or other trust boundary violations are at risk. When retrieving submission logs, Quill fetches a URL provided in the API response without validating that the scheme is https or that the host does not point to a local or multicast IP address. An attacker who can tamper with the response can supply an arbitrary URL, causing the Quill client to issue HTTP or HTTPS requests to attacker-controlled or internal network destinations. This could lead to exfiltration of sensitive data such as cloud provider credentials or internal service responses. Both the Quill CLI and library are affected when used to retrieve notarization submission logs. This vulnerability is fixed in 0.7.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-31959?

3 open source packages ship an affected version, including github.com/anchore/quill. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/anchore/quill` | Go | All versions | 0.7.1 |
| `github.com/anchore/quill` | Go | All versions | 0.7.1 |
| `github.com/anchore/quill` | Go | All versions | 0.7.1 |

Products: Anchore Quill.

## How do I fix CVE-2026-31959?

Upgrade github.com/anchore/quill to 0.7.1 or later.

## Is CVE-2026-31959 being exploited?

There is no known exploitation of CVE-2026-31959 in the wild and no public exploit code.

## Other vulnerabilities in anchore quill

- [CVE-2026-31961](https://insights.sbomify.com/CVE-2026-31961/): Unbounded memory allocation in Quill via unvalidated size fields in Mach-O binary parsing (medium 5.5)
- [CVE-2026-31960](https://insights.sbomify.com/CVE-2026-31960/): DoS in Quill via unbounded read of HTTP response body during notarization (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31959 and fix it if it is affected.

What it is: CVE-2026-31959 is a medium-severity server-side request forgery vulnerability in anchore quill, published on 11 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31959 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/anchore/quill (Go): affected all versions; fixed in 0.7.1
- github.com/anchore/quill (Go): affected all versions; fixed in 0.7.1
- github.com/anchore/quill (Go): affected all versions; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31959/ (Markdown: https://insights.sbomify.com/CVE-2026-31959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31959
- OSV: https://osv.dev/vulnerability/CVE-2026-31959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31959/
Summaries are generated and may contain mistakes; the official description above is the record.
