# CVE-2026-31961: Unbounded memory allocation in Quill via unvalidated size fields in Mach-O binary parsing

> An attacker can cause denial of service by supplying a crafted Mach-O binary that triggers unbounded memory allocation in Quill.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-xj69-m9qq-8m94, GO-2026-4675

## What is CVE-2026-31961?

CVE-2026-31961 is a medium-severity denial of service vulnerability in anchore quill, published on 11 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Quill provides simple mac binary signing and notarization from any platform. Quill before version v0.7.1 contains an unbounded memory allocation vulnerability when parsing Mach-O binaries. Exploitation requires that Quill processes an attacker-supplied Mach-O binary, which is most likely in environments such as CI/CD pipelines, shared signing services, or any workflow where externally-submitted binaries are accepted for signing. When parsing a Mach-O binary, Quill reads several size and count fields from the LC_CODE_SIGNATURE load command and embedded code signing structures (SuperBlob, BlobIndex) and uses them to allocate memory buffers without validating that the values are reasonable or consistent with the actual file size. Affected fields include DataSize, DataOffset, and Size from the load command, Count from the SuperBlob header, and Length from individual blob headers. An attacker can craft a minimal (~4KB) malicious Mach-O binary with extremely large values in these fields, causing Quill to attempt to allocate excessive memory. This leads to memory exhaustion and denial of service, potentially crashing the host process. Both the Quill CLI and Go library are affected when used to parse untrusted Mach-O files. This vulnerability is fixed in 0.7.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-31961?

3 open source packages ship an affected version, including github.com/anchore/quill. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/anchore/quill` | Go | All versions | 0.7.1 |
| `github.com/anchore/quill` | Go | All versions | 0.7.1 |
| `github.com/anchore/quill` | Go | All versions | 0.7.1 |

Products: Anchore Quill.

## How do I fix CVE-2026-31961?

Upgrade github.com/anchore/quill to 0.7.1 or later.

## Is CVE-2026-31961 being exploited?

There is no known exploitation of CVE-2026-31961 in the wild and no public exploit code.

## Other vulnerabilities in anchore quill

- [CVE-2026-31959](https://insights.sbomify.com/CVE-2026-31959/): SSRF in Quill via unvalidated URL from Apple notarization log retrieval (medium 5.3)
- [CVE-2026-31960](https://insights.sbomify.com/CVE-2026-31960/): DoS in Quill via unbounded read of HTTP response body during notarization (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31961 and fix it if it is affected.

What it is: CVE-2026-31961 is a medium-severity denial of service vulnerability in anchore quill, published on 11 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31961 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/anchore/quill (Go): affected all versions; fixed in 0.7.1
- github.com/anchore/quill (Go): affected all versions; fixed in 0.7.1
- github.com/anchore/quill (Go): affected all versions; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31961/ (Markdown: https://insights.sbomify.com/CVE-2026-31961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31961
- OSV: https://osv.dev/vulnerability/CVE-2026-31961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31961/
Summaries are generated and may contain mistakes; the official description above is the record.
