# CVE-2026-31987: Apache Airflow: JWT token appearing in logs

> Apache Airflow exposes JWT tokens in logs, allowing UI users to impersonate Dag Authors and escalate privileges.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2026
- **Updated:** 18 Apr 2026
- **Also known as:** BIT-airflow-2026-31987, ECHO-84a5-62f5-0d42, GHSA-phv5-vq5p-qhp7, MINI-47pc-977r-3mqr, PYSEC-2026-2352

## What is CVE-2026-31987?

CVE-2026-31987 is a high-severity vulnerability in Apache Airflow, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JWT Tokens used by tasks were exposed in logs. This could allow UI users to act as Dag Authors. 
Users are advised to upgrade to Airflow version that contains fix.

Users are recommended to upgrade to version 3.2.0, which fixes this issue.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-31987?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `airflow` | Bitnami | From 3.0.0 | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-31987?

Upgrade apache-airflow to 3.2.0 or later.

## Is CVE-2026-31987 being exploited?

There is no known exploitation of CVE-2026-31987 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31987 and fix it if it is affected.

What it is: CVE-2026-31987 is a high-severity vulnerability in Apache Airflow, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31987 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- airflow (Bitnami): affected from 3.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31987/ (Markdown: https://insights.sbomify.com/CVE-2026-31987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31987
- OSV: https://osv.dev/vulnerability/CVE-2026-31987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31987/
Summaries are generated and may contain mistakes; the official description above is the record.
