{"answers":{"affected":"2 open source packages ship an affected version, including yauzl.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31988 exists.","fix":"Upgrade yauzl to 3.2.1 or later.","what":"CVE-2026-31988 is a medium-severity denial of service vulnerability in thejoshwolfe yauzl, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-31988 and fix it if it is affected.\n\nWhat it is: CVE-2026-31988 is a medium-severity denial of service vulnerability in thejoshwolfe yauzl, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31988 exists.\n\nAffected packages and fixed versions:\n- yauzl (npm): affected from 3.2.0; fixed in 3.2.1\n- yauzl (npm): affected from 3.2.0; fixed in 3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-31988/ (Markdown: https://insights.sbomify.com/CVE-2026-31988/index.md)","id":"CVE-2026-31988","markdown":"https://insights.sbomify.com/CVE-2026-31988/index.md","name":"CVE-2026-31988","record":{"aliases":["ECHO-8347-6a0d-51d6","GHSA-gmq8-994r-jv83","MINI-22cx-g8jr-7fg7","MINI-2m86-62mx-874f","MINI-5ff9-68hf-p3v7","MINI-696q-7r8m-2793","MINI-7m3g-cw6r-j84q","MINI-959q-mg2x-hgx7","MINI-g58w-gxp2-g28r","MINI-hqvw-7cqr-mvhg","MINI-mq46-mwqx-pmh7","MINI-mrw8-gc3f-9gcg","MINI-rv7p-xccc-fj8f","MINI-w4g8-9hw3-rmqm","MINI-wjc5-6hv7-4883","ROOT-APP-NPM-CVE-2026-31988","UBUNTU-CVE-2026-31988"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js zip library","requires_auth":"none","summary":"A remote attacker can crash Node.js applications processing zip files by sending a crafted archive with a malformed NTFS timestamp field.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-193","name":"Off-by-one Error"}],"description":"yauzl (aka Yet Another Unzip Library) version 3.2.0 for Node.js contains an off-by-one error in the NTFS extended timestamp extra field parser within the getLastModDate() function. The while loop condition checks cursor \u003c data.length + 4 instead of cursor + 4 \u003c= data.length, allowing readUInt16LE() to read past the buffer boundary. A remote attacker can cause a denial of service (process crash via ERR_OUT_OF_RANGE exception) by sending a crafted zip file with a malformed NTFS extra field. This affects any Node.js application that processes zip file uploads and calls entry.getLastModDate() on parsed entries. Fixed in version 3.2.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"yauzl 3.2.0 - Denial of Service via Off-by-One Error in NTFS Timestamp Parser","id":"CVE-2026-31988","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"OpenClaw \u003c 2026.3.1 - Server-Side Request Forgery via web_search Citation Redirect","id":"CVE-2026-31989"},"packages":[{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["3.2.0"],"last_affected":[],"package":"yauzl","purl":null,"source":"GHSA-gmq8-994r-jv83"},{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["3.2.0"],"last_affected":[],"package":"yauzl","purl":"pkg:npm/yauzl","source":"GHSA-gmq8-994r-jv83"}],"prev":{"headline":"Apache Airflow: JWT token appearing in logs","id":"CVE-2026-31987"},"products":["yauzl"],"published":"2026-03-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-12","vendors":["thejoshwolfe"]},"summary":"A remote attacker can crash Node.js applications processing zip files by sending a crafted archive with a malformed NTFS timestamp field.","url":"https://insights.sbomify.com/CVE-2026-31988/"}