CVE-2026-31998 OpenClaw 2026.2.22 < 2026.2.24 - Authorization Bypass in Synology Chat Plugin via Empty allowedUserIds

High 8.3 Published Updated

Attackers can bypass authorization in OpenClaw's Synology Chat plugin when configured with an empty allowlist, triggering unauthorized agent actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-31998?

CVE-2026-31998 is a high-severity missing authorization vulnerability in Openclaw Openclaw, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw versions 2026.2.22 and 2026.2.23 contain an authorization bypass vulnerability in the synology-chat channel plugin where dmPolicy set to allowlist with empty allowedUserIds fails open. Attackers with Synology sender access can bypass authorization checks and trigger unauthorized agent dispatch and downstream tool actions.

Weakness: CWE-863

Which versions are affected by CVE-2026-31998?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.2.222026.2.24
openclaw npmFrom 2026.2.222026.2.24

Products include Openclaw Openclaw.

How do I fix CVE-2026-31998?

Upgrade openclaw to 2026.2.24 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-31998 being exploited?

There is no known exploitation of CVE-2026-31998 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-gw85-xp4q-5gp9, MINI-2w4c-gmjj-m2w7, MINI-5vq9-m9fx-4vrw.

Is CVE-2026-31998 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free