CVE-2026-32015 OpenClaw 2026.1.21 < 2026.2.19 - PATH Hijacking Bypass in tools.exec.safeBins Allowlist Validation

High 7.3 Published Updated

Attackers can bypass executable allowlists by manipulating the PATH environment variable to execute trojan binaries, leading to arbitrary code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32015?

CVE-2026-32015 is a high-severity vulnerability in Openclaw Openclaw, published on 19 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenClaw versions 2026.1.21 prior to 2026.2.19 contain a path hijacking vulnerability in tools.exec.safeBins that allows attackers to bypass allowlist checks by controlling process PATH resolution. Attackers who can influence the gateway process PATH or launch environment can execute trojan binaries with allowlisted names, such as jq, circumventing executable validation controls.

Weakness: CWE-426

Which versions are affected by CVE-2026-32015?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.1.212026.2.19
openclaw npmFrom 2026.1.212026.2.19

Products include Openclaw Openclaw.

How do I fix CVE-2026-32015?

Upgrade openclaw to 2026.2.19 or later.

Is CVE-2026-32015 being exploited?

There is no known exploitation of CVE-2026-32015 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-g75x-8qqm-2vxp, MINI-h58g-m9gq-cmv3.

Is CVE-2026-32015 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free