# CVE-2026-32015: OpenClaw 2026.1.21 < 2026.2.19 - PATH Hijacking Bypass in tools.exec.safeBins Allowlist Validation

> Attackers can bypass executable allowlists by manipulating the PATH environment variable to execute trojan binaries, leading to arbitrary code execution.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-g75x-8qqm-2vxp, MINI-h58g-m9gq-cmv3

## What is CVE-2026-32015?

CVE-2026-32015 is a high-severity vulnerability in Openclaw Openclaw, published on 19 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenClaw versions 2026.1.21 prior to 2026.2.19 contain a path hijacking vulnerability in tools.exec.safeBins that allows attackers to bypass allowlist checks by controlling process PATH resolution. Attackers who can influence the gateway process PATH or launch environment can execute trojan binaries with allowlisted names, such as jq, circumventing executable validation controls.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-32015?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | From 2026.1.21 | 2026.2.19 |
| `openclaw` | npm | From 2026.1.21 | 2026.2.19 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-32015?

Upgrade openclaw to 2026.2.19 or later.

## Is CVE-2026-32015 being exploited?

There is no known exploitation of CVE-2026-32015 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32015 and fix it if it is affected.

What it is: CVE-2026-32015 is a high-severity vulnerability in Openclaw Openclaw, published on 19 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32015 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected from 2026.1.21; fixed in 2026.2.19
- openclaw (npm): affected from 2026.1.21; fixed in 2026.2.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32015/ (Markdown: https://insights.sbomify.com/CVE-2026-32015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32015
- OSV: https://osv.dev/vulnerability/CVE-2026-32015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32015/
Summaries are generated and may contain mistakes; the official description above is the record.
