CVE-2026-32017 OpenClaw < 2026.2.19 - Arbitrary File Write via Short-Option Bypass in exec Allowlist
Attackers can bypass exec allowlist restrictions to write arbitrary files, potentially leading to code execution in OpenClaw.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32017?
CVE-2026-32017 is a medium-severity vulnerability in Openclaw Openclaw, published on 19 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw versions prior to 2026.2.19 contain an allowlist bypass vulnerability in the exec safeBins policy that allows attackers to write arbitrary files using short-option payloads. Attackers can bypass argument validation by attaching short options like -o to whitelisted binaries, enabling unauthorized file-write operations that should be denied by safeBins checks.
Weakness: CWE-184
Which versions are affected by CVE-2026-32017?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.2.19 |
openclaw npm | All versions | 2026.2.19 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-32017?
Upgrade openclaw to 2026.2.19 or later.
Is CVE-2026-32017 being exploited?
There is no known exploitation of CVE-2026-32017 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-3x3x-h76w-hp98, MINI-vgmp-cx5g-5mcr.