CVE-2026-32019 OpenClaw < 2026.2.22 - Incomplete IPv4 Special-Use Range Blocking in SSRF Guard

Low 2.3 Published Updated

Attackers can bypass SSRF protections to access reserved IPv4 ranges via web_fetch, potentially exposing internal or restricted network resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32019?

CVE-2026-32019 is a low-severity server-side request forgery vulnerability in Openclaw Openclaw, published on 19 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenClaw versions prior to 2026.2.22 contain incomplete IPv4 special-use range validation in the isPrivateIpv4() function, allowing requests to RFC-reserved ranges to bypass SSRF policy checks. Attackers with network reachability to special-use IPv4 ranges can exploit web_fetch functionality to access blocked addresses such as 198.18.0.0/15 and other non-global ranges.

Weakness: CWE-918

Which versions are affected by CVE-2026-32019?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.2.22
openclaw npmAll versions2026.2.22

Products include Openclaw Openclaw.

How do I fix CVE-2026-32019?

Upgrade openclaw to 2026.2.22 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-32019 being exploited?

There is no known exploitation of CVE-2026-32019 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-4rqq-w8v4-7p47, MINI-rmmr-fr5h-hf2r.

Is CVE-2026-32019 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free