CVE-2026-32042 OpenClaw < 2026.2.25 - Privilege Escalation via Unpaired Device Identity in Shared Gateway Authentication

High 8.7 Published Updated

Attackers with valid shared gateway authentication can bypass pairing requirements to self-assign elevated operator scopes, including admin privileges.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32042?

CVE-2026-32042 is a high-severity vulnerability in Openclaw Openclaw, published on 21 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenClaw versions 2026.2.22 prior to 2026.2.25 contain a privilege escalation vulnerability allowing unpaired device identities to bypass operator pairing requirements and self-assign elevated operator scopes including operator.admin. Attackers with valid shared gateway authentication can present a self-signed unpaired device identity to request and obtain higher operator scopes before pairing approval is granted.

Weakness: CWE-863

Which versions are affected by CVE-2026-32042?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.2.222026.2.25
openclaw npmFrom 2026.2.222026.2.25

Products include Openclaw Openclaw.

How do I fix CVE-2026-32042?

Upgrade openclaw to 2026.2.25 or later.

Is CVE-2026-32042 being exploited?

There is no known exploitation of CVE-2026-32042 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-553v-f69r-656j, GHSA-r3gm-fv85-xjqj, MINI-p7vr-cq2p-jfrj, MINI-xjhw-9wvp-f7x4.

Is CVE-2026-32042 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free