CVE-2026-32063 OpenClaw 2026.2.19-2 < 2026.2.21 - Command Injection via Newline in systemd Unit Generation

Medium 6.9 Published Updated

Attackers can inject arbitrary commands via newline characters in environment variables during systemd unit generation, leading to code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32063?

CVE-2026-32063 is a medium-severity command injection vulnerability in Openclaw Openclaw, published on 11 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenClaw version 2026.2.19-2 prior to 2026.2.21 contains a command injection vulnerability in systemd unit file generation where attacker-controlled environment values are not validated for CR/LF characters, allowing newline injection to break out of Environment= lines and inject arbitrary systemd directives. An attacker who can influence config.env.vars and trigger service install or restart can execute arbitrary commands with the privileges of the OpenClaw gateway service user.

Weakness: CWE-77

Which versions are affected by CVE-2026-32063?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.2.21
openclaw npmAll versions2026.2.21

Products include Openclaw Openclaw.

How do I fix CVE-2026-32063?

Upgrade openclaw to 2026.2.21 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-32063 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32063 exists.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-vffc-f7r7-rx2w, MINI-r7wq-43qg-crm4.

Is CVE-2026-32063 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free