CVE-2026-32098 Parse Server has a protected fields bypass via LiveQuery subscription WHERE clause
Attackers can infer protected field values in Parse Server by using LiveQuery subscriptions as a boolean oracle, leaking sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32098?
CVE-2026-32098 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.9 and 8.6.35, an attacker can exploit LiveQuery subscriptions to infer the values of protected fields without directly receiving them. By subscribing with a WHERE clause that references a protected field (including via dot-notation or $regex), the attacker can observe whether LiveQuery events are delivered for matching objects. This creates a boolean oracle that leaks protected field values. The attack affects any class that has both protectedFields configured in Class-Level Permissions and LiveQuery enabled. This vulnerability is fixed in 9.6.0-alpha.9 and 8.6.35.
Weakness: CWE-200
Which versions are affected by CVE-2026-32098?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.35 |
parse-server npm | All versions | 8.6.35 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.9 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.9 |
parse Bitnami | All versions | 8.6.35, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-32098?
Upgrade parse-server to a fixed version for your release line: 8.6.35 or 9.6.0-alpha.9.
Is CVE-2026-32098 being exploited?
There is no known exploitation of CVE-2026-32098 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-32098, GHSA-j7mm-f4rv-6q6q.