# CVE-2026-32109: Copyparty has unexpected JavaScript execution via crafted URL to folder with `.prologue.html`

> An attacker with write access can upload a malicious file to execute arbitrary JavaScript in a victim's browser via a crafted URL.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-rcp6-88mm-9vgf, PYSEC-2026-32

## What is CVE-2026-32109?

CVE-2026-32109 is a low-severity cross-site scripting vulnerability in 9001 copyparty, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Copyparty is a portable file server. Prior to 1.20.12, if an attacker has been given both read- and write-permissions to the server, they can upload a malicious file with the filename .prologue.html and then craft a link to potentially execute arbitrary JavaScript in the victim's context. Note that it is intended behavior that the JavaScript would execute if the target clicks a link to the HTML file itself; "https://example.com/foo/.prologue.html". The vulnerability is that "https://example.com/foo/?b" would also evaluate the file, making the behavior unexpected. There are existing preventative measures (strict SameSite cookies) which makes it harder to leverage this vulnerability in an attack; in order to gain control of the target's authenticated session, the link must be clicked from a page served by the server itself -- most likely by editing an existing resource, which would require additional access permissions. Finally, for this attack to be successful, the attacker's target must click the specific crafted link given by the attacker. This vulnerability is not activated by normally browsing the web-UI on the server. This vulnerability is fixed in 1.20.12.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-32109?

3 open source packages ship an affected version, including copyparty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.20.12 |
| `copyparty` | PyPI | All versions | 1.20.12 |
| `copyparty` | PyPI | All versions | 1.20.12 |

Products: 9001 Copyparty.

## How do I fix CVE-2026-32109?

Upgrade copyparty to 1.20.12 or later.

## Is CVE-2026-32109 being exploited?

There is no known exploitation of CVE-2026-32109 in the wild and no public exploit code.

## Other vulnerabilities in 9001 copyparty

- [CVE-2023-41471](https://insights.sbomify.com/CVE-2023-41471/): Cross-site scripting in n/a (high 7.8)
- [CVE-2025-54796](https://insights.sbomify.com/CVE-2025-54796/): Copyparty is vulnerable to Regex Denial of Service (ReDoS) attacks through "Recent Uploads" page (high 7.5)
- [CVE-2023-37474](https://insights.sbomify.com/CVE-2023-37474/): Path traversal in copyparty (high 7.5)
- [CVE-2025-54589](https://insights.sbomify.com/CVE-2025-54589/): copyparty Reflected XSS via Filter Parameter (medium 6.3)
- [CVE-2023-38501](https://insights.sbomify.com/CVE-2023-38501/): copyparty vulnerable to reflected cross-site scripting via k304 parameter (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32109 and fix it if it is affected.

What it is: CVE-2026-32109 is a low-severity cross-site scripting vulnerability in 9001 copyparty, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32109 in the wild and no public exploit code.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.20.12
- copyparty (PyPI): affected all versions; fixed in 1.20.12
- copyparty (PyPI): affected all versions; fixed in 1.20.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32109/ (Markdown: https://insights.sbomify.com/CVE-2026-32109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32109
- OSV: https://osv.dev/vulnerability/CVE-2026-32109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32109/
Summaries are generated and may contain mistakes; the official description above is the record.
