CVE-2026-32113 Discourse: Open redirect via `sso_destination_url` cookie in `enter`
Attackers can redirect users to malicious sites via a crafted cookie in Discourse, bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-32113?
CVE-2026-32113 is a medium-severity vulnerability in Discourse Discourse, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, the enter action in StaticController reads the sso_destination_url cookie and redirects to it with allow_other_host: true without validating the destination URL. While this cookie is normally set during legitimate DiscourseConnect Provider flows with cryptographically validated SSO payloads, cookies are client-controlled and can be set by attackers. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Weakness: CWE-601
Which versions are affected by CVE-2026-32113?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.3, 2026.2.2 |
Products include Discourse Discourse.
How do I fix CVE-2026-32113?
Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.
Is CVE-2026-32113 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32113 exists.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-32113, GHSA-378j-ccw4-4fwh.