CVE-2026-32114 Discourse's unscoped status lookups leak restricted metadata
Authenticated users can access restricted AI persona metadata and usage statistics via insecure direct object references.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32114?
CVE-2026-32114 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, there is an Insecure Direct Object Reference (IDOR) vulnerability that allows any authenticated user to access metadata about AI personas, features, and LLM models by providing their identifiers. This information includes credit allocations and usage statistics which are not intended to be public. The attack is performed over the network, requires low privileges (any logged-in user), and results in a low impact on confidentiality with no impact on integrity or availability. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. To work around this issue, disable AI plugin or upgrade to a patched version.
Weakness: CWE-639
Which versions are affected by CVE-2026-32114?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.2, 2026.2.1, 2026.3.0 |
Products include Discourse Discourse.
How do I fix CVE-2026-32114?
Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-32114 being exploited?
There is no known exploitation of CVE-2026-32114 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-32114, GHSA-3cvr-pm4c-hx96.