CVE-2026-32143 Discourse: Admin-only report can be exported by moderators

Medium 5.3 Published Updated

Moderators can export admin-only reports, exposing sensitive operational data intended for administrators only.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32143?

CVE-2026-32143 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, moderators could export CSV data for admin-restricted reports, bypassing the report visibility restrictions. This could expose sensitive operational data intended only for admins. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Weakness: CWE-200

Which versions are affected by CVE-2026-32143?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.3, 2026.2.2

Products include Discourse Discourse.

How do I fix CVE-2026-32143?

Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-32143 being exploited?

There is no known exploitation of CVE-2026-32143 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-32143, GHSA-rhjf-mgqw-37wq.

Is CVE-2026-32143 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free