{"answers":{"affected":"3 open source packages ship an affected version, including wisp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32145 in the wild and no public exploit code.","fix":"Upgrade wisp to 2.2.2 or later.","what":"CVE-2026-32145 is a high-severity denial of service vulnerability in gleam-wisp wisp, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32145 and fix it if it is affected.\n\nWhat it is: CVE-2026-32145 is a high-severity denial of service vulnerability in gleam-wisp wisp, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32145 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wisp (Hex): affected all versions; fixed in 2.2.2\n- wisp (Hex): affected all versions; fixed in 2.2.2\n- wisp (Hex): affected from 0.2.0; fixed in 2.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32145/ (Markdown: https://insights.sbomify.com/CVE-2026-32145/index.md)","id":"CVE-2026-32145","markdown":"https://insights.sbomify.com/CVE-2026-32145/index.md","name":"CVE-2026-32145","record":{"aliases":["EEF-CVE-2026-32145","GHSA-8645-p2v4-73r2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Gleam web library","requires_auth":"none","summary":"An unauthenticated attacker can cause denial of service by exhausting server resources through multipart form submissions that bypass size limits.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[{"product":"wisp","vendor":"gleam-wisp"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Allocation of Resources Without Limits or Throttling vulnerability in gleam-wisp wisp allows a denial of service via multipart form body parsing.\n\nThe multipart_body function bypasses configured max_body_size and max_files_size limits. When a multipart boundary is not present in a chunk, the parser takes the MoreRequiredForBody path, which appends the chunk to the output but passes the quota unchanged to the recursive call. Only the final chunk containing the boundary is counted via decrement_quota. The same pattern exists in multipart_headers, where MoreRequiredForHeaders recurses without calling decrement_body_quota.\n\nAn unauthenticated attacker can exhaust server memory or disk by sending arbitrarily large multipart form submissions in a single HTTP request.\n\nThis issue affects wisp: from 0.2.0 before 2.2.2.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Multipart form body parser bypasses body size limits in wisp","id":"CVE-2026-32145","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Improper Path Validation in Git Dependency Handling Allows Arbitrary File System Modification","id":"CVE-2026-32146"},"packages":[{"ecosystem":"Hex","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"wisp","purl":null,"source":"GHSA-8645-p2v4-73r2"},{"ecosystem":"Hex","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"wisp","purl":"pkg:hex/wisp","source":"GHSA-8645-p2v4-73r2"},{"ecosystem":"Hex","fixed":["2.2.2"],"introduced":["0.2.0"],"last_affected":[],"package":"wisp","purl":"pkg:hex/wisp","source":"EEF-CVE-2026-32145"}],"prev":{"headline":"OCSP designated-responder authorization bypass via missing signature verification","id":"CVE-2026-32144"},"products":["wisp"],"published":"2026-04-02","related":[{"cvss_score":8.7,"headline":"Path Traversal in wisp.serve_static allows arbitrary file read","id":"CVE-2026-28807","kev_date_added":null,"published":"2026-03-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-07","vendors":["gleam-wisp"]},"summary":"An unauthenticated attacker can cause denial of service by exhausting server resources through multipart form submissions that bypass size limits.","url":"https://insights.sbomify.com/CVE-2026-32145/"}