# CVE-2026-32145: Multipart form body parser bypasses body size limits in wisp

> An unauthenticated attacker can cause denial of service by exhausting server resources through multipart form submissions that bypass size limits.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** EEF-CVE-2026-32145, GHSA-8645-p2v4-73r2

## What is CVE-2026-32145?

CVE-2026-32145 is a high-severity denial of service vulnerability in gleam-wisp wisp, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in gleam-wisp wisp allows a denial of service via multipart form body parsing.

The multipart_body function bypasses configured max_body_size and max_files_size limits. When a multipart boundary is not present in a chunk, the parser takes the MoreRequiredForBody path, which appends the chunk to the output but passes the quota unchanged to the recursive call. Only the final chunk containing the boundary is counted via decrement_quota. The same pattern exists in multipart_headers, where MoreRequiredForHeaders recurses without calling decrement_body_quota.

An unauthenticated attacker can exhaust server memory or disk by sending arbitrarily large multipart form submissions in a single HTTP request.

This issue affects wisp: from 0.2.0 before 2.2.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-32145?

3 open source packages ship an affected version, including wisp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wisp` | Hex | All versions | 2.2.2 |
| `wisp` | Hex | All versions | 2.2.2 |
| `wisp` | Hex | From 0.2.0 | 2.2.2 |

Products: Gleam-Wisp Wisp.

## How do I fix CVE-2026-32145?

Upgrade wisp to 2.2.2 or later.

## Is CVE-2026-32145 being exploited?

There is no known exploitation of CVE-2026-32145 in the wild and no public exploit code.

## Other vulnerabilities in gleam-wisp wisp

- [CVE-2026-28807](https://insights.sbomify.com/CVE-2026-28807/): Path Traversal in wisp.serve_static allows arbitrary file read (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32145 and fix it if it is affected.

What it is: CVE-2026-32145 is a high-severity denial of service vulnerability in gleam-wisp wisp, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32145 in the wild and no public exploit code.

Affected packages and fixed versions:
- wisp (Hex): affected all versions; fixed in 2.2.2
- wisp (Hex): affected all versions; fixed in 2.2.2
- wisp (Hex): affected from 0.2.0; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32145/ (Markdown: https://insights.sbomify.com/CVE-2026-32145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32145
- OSV: https://osv.dev/vulnerability/CVE-2026-32145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32145/
Summaries are generated and may contain mistakes; the official description above is the record.
