# CVE-2026-32234: Parse Server has a SQL injection via query field name when using PostgreSQL

> Attackers with master key access can inject SQL via query field names in PostgreSQL deployments, bypassing application controls to manipulate the database.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** BIT-parse-2026-32234, GHSA-c442-97qw-j6c6

## What is CVE-2026-32234?

CVE-2026-32234 is a medium-severity SQL injection vulnerability in Parseplatform Parse-Server, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.10 and 8.6.36, an attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a $regex query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level. This vulnerability only affects Parse Server deployments using PostgreSQL. This vulnerability is fixed in 9.6.0-alpha.10 and 8.6.36.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-32234?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.36 |
| `parse-server` | npm | All versions | 8.6.36 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.10 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.10 |
| `parse` | Bitnami | All versions | 8.6.36, 9.6.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-32234?

Upgrade parse-server to a fixed version for your release line: 8.6.36 or 9.6.0-alpha.10.

## Is CVE-2026-32234 being exploited?

There is no known exploitation of CVE-2026-32234 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32234 and fix it if it is affected.

What it is: CVE-2026-32234 is a medium-severity SQL injection vulnerability in Parseplatform Parse-Server, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32234 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.36
- parse-server (npm): affected all versions; fixed in 8.6.36
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.10
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.10
- parse (Bitnami): affected all versions; fixed in 8.6.36, 9.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32234/ (Markdown: https://insights.sbomify.com/CVE-2026-32234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32234
- OSV: https://osv.dev/vulnerability/CVE-2026-32234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32234/
Summaries are generated and may contain mistakes; the official description above is the record.
