# CVE-2026-32235: @backstage/plugin-auth-backend: OAuth redirect URI allowlist bypass

> Attackers can bypass OAuth redirect URI allowlists in experimental Backstage auth features to steal authorization codes and access tokens.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-wqvh-63mv-9w92, ROOT-APP-NPM-CVE-2026-32235

## What is CVE-2026-32235?

CVE-2026-32235 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.27.1, the experimental OIDC provider in @backstage/plugin-auth-backend is vulnerable to a redirect URI allowlist bypass. Instances that have enabled experimental Dynamic Client Registration or Client ID Metadata Documents and configured allowedRedirectUriPatterns are affected. A specially crafted redirect URI can pass the allowlist validation while resolving to an attacker-controlled host. If a victim approves the resulting OAuth consent request, their authorization code is sent to the attacker, who can exchange it for a valid access token. This requires victim interaction and that one of the experimental features is explicitly enabled, which is not the default. This vulnerability is fixed in 0.27.1.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-32235?

2 open source packages ship an affected version, including @backstage/plugin-auth-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-auth-backend` | npm | All versions | 0.27.1 |
| `@backstage/plugin-auth-backend` | npm | All versions | 0.27.1 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2026-32235?

Upgrade @backstage/plugin-auth-backend to 0.27.1 or later.

## Is CVE-2026-32235 being exploited?

There is no known exploitation of CVE-2026-32235 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32235 and fix it if it is affected.

What it is: CVE-2026-32235 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32235 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-auth-backend (npm): affected all versions; fixed in 0.27.1
- @backstage/plugin-auth-backend (npm): affected all versions; fixed in 0.27.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32235/ (Markdown: https://insights.sbomify.com/CVE-2026-32235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32235
- OSV: https://osv.dev/vulnerability/CVE-2026-32235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32235/
Summaries are generated and may contain mistakes; the official description above is the record.
