# CVE-2026-32236: @backstage/plugin-auth-backend: SSRF in experimental CIMD metadata fetch

> An SSRF vulnerability in the Backstage auth plugin allows bypassing IP restrictions during redirects when an experimental feature is enabled.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-qp4c-xg64-7c6x, ROOT-APP-NPM-CVE-2026-32236

## What is CVE-2026-32236?

CVE-2026-32236 is a low-severity server-side request forgery vulnerability in Linuxfoundation Backstage, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.27.1, a Server-Side Request Forgery (SSRF) vulnerability exists in @backstage/plugin-auth-backend when auth.experimentalClientIdMetadataDocuments.enabled is set to true. The CIMD
metadata fetch validates the initial client_id hostname against private IP ranges but does not apply the same validation after HTTP redirects. The practical impact is limited. The attacker cannot read the response body from the internal request, cannot control request headers or method, and the feature must be explicitly enabled via an experimental flag that is off by default. Deployments that restrict allowedClientIdPatterns to specific trusted domains are not affected. Patched in @backstage/plugin-auth-backend version 0.27.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-32236?

2 open source packages ship an affected version, including @backstage/plugin-auth-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-auth-backend` | npm | All versions | 0.27.1 |
| `@backstage/plugin-auth-backend` | npm | All versions | 0.27.1 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2026-32236?

Upgrade @backstage/plugin-auth-backend to 0.27.1 or later.

## Is CVE-2026-32236 being exploited?

There is no known exploitation of CVE-2026-32236 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32236 and fix it if it is affected.

What it is: CVE-2026-32236 is a low-severity server-side request forgery vulnerability in Linuxfoundation Backstage, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32236 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-auth-backend (npm): affected all versions; fixed in 0.27.1
- @backstage/plugin-auth-backend (npm): affected all versions; fixed in 0.27.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32236/ (Markdown: https://insights.sbomify.com/CVE-2026-32236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32236
- OSV: https://osv.dev/vulnerability/CVE-2026-32236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32236/
Summaries are generated and may contain mistakes; the official description above is the record.
