# CVE-2026-32237: @backstage/plugin-scaffolder-backend: Possible exposure of defaultEnvironment secrets using dry-run endpoint

> Authenticated users can access server-configured environment secrets via the scaffolder dry-run endpoint if default environment secrets are configured.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-8wq8-6859-qx77

## What is CVE-2026-32237?

CVE-2026-32237 is a medium-severity vulnerability in @backstage plugin-scaffolder-backend, published on 12 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 3.1.5, authenticated users with permission to execute scaffolder dry-runs can gain access to server-configured environment secrets through the dry-run API response. Secrets are properly redacted in log output but not in all parts of the response payload. Deployments that have configured scaffolder.defaultEnvironment.secrets are affected. This is patched in @backstage/plugin-scaffolder-backend version 3.1.5.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-32237?

2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | From 3.1.0 | 3.1.5 |
| `@backstage/plugin-scaffolder-backend` | npm | From 3.1.0 | 3.1.5 |

Products: Linuxfoundation Backstage\/Plugin-Scaffolder-Backend.

## How do I fix CVE-2026-32237?

Upgrade @backstage/plugin-scaffolder-backend to 3.1.5 or later.

## Is CVE-2026-32237 being exploited?

There is no known exploitation of CVE-2026-32237 in the wild and no public exploit code.

## Other vulnerabilities in @backstage plugin-scaffolder-backend

- [CVE-2026-29184](https://insights.sbomify.com/CVE-2026-29184/): @backstage/plugin-scaffolder-backend: Potential Session Token Exfiltration via Log Redaction Bypass (low 2.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32237 and fix it if it is affected.

What it is: CVE-2026-32237 is a medium-severity vulnerability in @backstage plugin-scaffolder-backend, published on 12 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32237 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected from 3.1.0; fixed in 3.1.5
- @backstage/plugin-scaffolder-backend (npm): affected from 3.1.0; fixed in 3.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32237/ (Markdown: https://insights.sbomify.com/CVE-2026-32237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32237
- OSV: https://osv.dev/vulnerability/CVE-2026-32237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32237/
Summaries are generated and may contain mistakes; the official description above is the record.
