CVE-2026-32243 Discourse: Stored XSS in discourse-ai shared conversations onebox
Attackers can inject malicious scripts into AI conversation titles, leading to session hijacking or unauthorized actions for users viewing the preview.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32243?
CVE-2026-32243 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, an attacker with the ability to create shared AI conversations could inject arbitrary HTML and JavaScript via crafted conversation titles. This payload would execute in the browser of any user viewing the onebox preview, potentially allowing session hijacking or unauthorized actions on behalf of the victim. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-32243?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.3, 2026.2.2 |
Products include Discourse Discourse.
How do I fix CVE-2026-32243?
Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-32243 being exploited?
There is no known exploitation of CVE-2026-32243 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-32243, GHSA-pjc5-8x3w-rfwx.