CVE-2026-32244 Discourse: Cached outdated summaries can leak removed content

Medium 5.3 Published Updated

Attackers can view removed content via outdated cached AI summaries, exposing sensitive data to unauthorized users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32244?

CVE-2026-32244 is a medium-severity vulnerability in Discourse Discourse, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, outdated cached AI summaries can leak removed content to anonymous and unprivileged users who cannot regenerate summaries. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1. To work around this issue, restrict summary generation by tightening the allowed groups on the summarization Personas.

Weakness: CWE-672, CWE-524, CWE-200

Which versions are affected by CVE-2026-32244?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2026.1.4, 2026.3.1, 2026.4.1

Products include Discourse Discourse.

How do I fix CVE-2026-32244?

Upgrade discourse to a fixed version for your release line: 2026.1.4, 2026.3.1 or 2026.4.1.

Is CVE-2026-32244 being exploited?

There is no known exploitation of CVE-2026-32244 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-32244, GHSA-hjmg-2mww-vfvx.

Is CVE-2026-32244 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free