CVE-2026-32248 Parse Server: Account takeover via operator injection in authentication data identifier
Unauthenticated attackers can take over user accounts by injecting operators into authentication identifiers, bypassing exact-match checks in Parse Server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32248?
CVE-2026-32248 is a critical authentication bypass vulnerability in Parseplatform Parse-Server, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.
Weakness: CWE-943
Which versions are affected by CVE-2026-32248?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.38 |
parse-server npm | All versions | 8.6.38 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.12 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.12 |
parse Bitnami | All versions | 8.6.38, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-32248?
Upgrade parse-server to a fixed version for your release line: 8.6.38 or 9.6.0-alpha.12.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-32248 being exploited?
There is no known exploitation of CVE-2026-32248 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-32248, GHSA-5fw2-8jcv-xh87.