CVE-2026-32258 Winter: Stored XSS through Editor Settings custom styles
Authenticated users with editor permissions can inject malicious scripts via custom styles, leading to stored XSS in the backend.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-32258?
CVE-2026-32258 is a high-severity cross-site scripting vulnerability in wintercms winter, published on 26 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Winter is a free, open-source content management system (CMS) based on the Laravel PHP framework. From 1.2.10 through 1.2.12, authenticated backend users with the backend.manage_editor permission can store custom Markup Styles that are compiled by the LESS parser and rendered without sanitization on every backend page, allowing stored cross-site scripting. This issue is fixed in version 1.2.13.
Weakness: CWE-79
Which versions are affected by CVE-2026-32258?
2 open source packages ship an affected version, including winter/wn-backend-module.
| Package | Affected | Fixed in |
|---|---|---|
winter/wn-backend-module Packagist | From 1.2.10 | 1.2.13 |
winter/wn-backend-module Packagist | From 1.2.10 | 1.2.13 |
How do I fix CVE-2026-32258?
Upgrade winter/wn-backend-module to 1.2.13 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-32258 being exploited?
There is no known exploitation of CVE-2026-32258 in the wild and no public exploit code.
Sources
Also known as GHSA-vgp4-2fc4-qff2.