CVE-2026-32259 ImageMagick has a possible stack buffer overflow in sixel encoder

Medium 6.7 Published Updated

A stack buffer overflow in ImageMagick's sixel encoder allows attackers to execute arbitrary code or cause denial of service via crafted images.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32259?

CVE-2026-32259 is a medium-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 12 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-16 and 6.9.13-41, when a memory allocation fails in the sixel encoder it would be possible to write past the end of a buffer on the stack. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.

Weakness: CWE-121

Which versions are affected by CVE-2026-32259?

It affects 1 product.

Products include Imagemagick Imagemagick.

How do I fix CVE-2026-32259?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-32259 being exploited?

There is no known exploitation of CVE-2026-32259 in the wild and no public exploit code.

All Imagemagick Imagemagick vulnerabilities

Sources

Also known as CLSA-2026-1786355721, DEBIAN-CVE-2026-32259, ECHO-3b81-22ae-0c1a, GHSA-49hx-7656-jpg3, JLSEC-2026-989, MINI-fh6j-xgf5-f9xm and 1 more.

Is CVE-2026-32259 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free