CVE-2026-32264 Craft CMS vulnerable to behavior injection RCE ElementIndexesController and FieldsController
Craft CMS administrators can achieve remote code execution via behavior injection in specific controllers when admin changes are allowed.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32264?
CVE-2026-32264 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 16 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.5 and from version 5.0.0-RC1 to before version 5.9.11, there is a Behavior injection RCE vulnerability in ElementIndexesController and FieldsController. Craft control panel administrator permissions and allowAdminChanges must be enabled for this to work. This issue has been patched in versions 4.17.5 and 5.9.11.
Weakness: CWE-470
Which versions are affected by CVE-2026-32264?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.5 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.5 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.11 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.11 |
Products include Craftcms Craft Cms.
How do I fix CVE-2026-32264?
Upgrade craftcms/cms to a fixed version for your release line: 4.17.5 or 5.9.11.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-32264 being exploited?
There is no known exploitation of CVE-2026-32264 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-4484-8v2f-5748.