# CVE-2026-32266: Google Cloud Storage for Craft CMS has an Information Disclosure Vulnerability

> Unauthenticated users can view a list of accessible Google Cloud Storage buckets via the plugin's load bucket data endpoint.

- **Severity:** Low 2.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-67cr-jmh8-4jpq

## What is CVE-2026-32266?

CVE-2026-32266 is a low-severity vulnerability in craftcms google-cloud, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Google Cloud Storage for Craft CMS plugin provides a Google Cloud Storage integration for Craft CMS. In versions on the 2.x branch prior to 2.2.1, the `DefaultController->actionLoadBucketData()` endpoint allows unauthenticated users with a valid CSRF token to view a list of buckets that the plugin is allowed to see. Users should update to version 2.2.1 of the plugin to mitigate the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-32266?

2 open source packages ship an affected version, including craftcms/google-cloud.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/google-cloud` | Packagist | From 2.0.0-beta.1 | 2.2.1 |
| `craftcms/google-cloud` | Packagist | From 2.0.0-beta.1 | 2.2.1 |

## How do I fix CVE-2026-32266?

Upgrade craftcms/google-cloud to 2.2.1 or later.

## Is CVE-2026-32266 being exploited?

There is no known exploitation of CVE-2026-32266 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32266 and fix it if it is affected.

What it is: CVE-2026-32266 is a low-severity vulnerability in craftcms google-cloud, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32266 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/google-cloud (Packagist): affected from 2.0.0-beta.1; fixed in 2.2.1
- craftcms/google-cloud (Packagist): affected from 2.0.0-beta.1; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32266/ (Markdown: https://insights.sbomify.com/CVE-2026-32266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32266
- OSV: https://osv.dev/vulnerability/CVE-2026-32266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32266/
Summaries are generated and may contain mistakes; the official description above is the record.
