CVE-2026-32267 Craft CMS Vulnerable to Privilege Escalation/Bypass through UsersController->actionImpersonateWithToken()
Low-privilege or unauthenticated users can escalate to admin privileges by abusing the impersonation token feature in Craft CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32267?
CVE-2026-32267 is a high-severity vulnerability in Craftcms Craft Cms, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.6 and from version 5.0.0-RC1 to before version 5.9.12, a low-privilege user (or an unauthenticated user who has been sent a shared URL) can escalate their privileges to admin by abusing UsersController->actionImpersonateWithToken. This issue has been patched in versions 4.17.6 and 5.9.12.
Weakness: CWE-863
Which versions are affected by CVE-2026-32267?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.6 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.6 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.12 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.12 |
Products include Craftcms Craft Cms.
How do I fix CVE-2026-32267?
Upgrade craftcms/cms to a fixed version for your release line: 4.17.6 or 5.9.12.
Is CVE-2026-32267 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32267 exists.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-cc7p-2j3x-x7xf.