# CVE-2026-32268: Azure Blob Storage for Craft CMS Potential Sensitive Information Disclosure vulnerability

> Unauthenticated users can view Azure Blob Storage bucket lists via an unprotected endpoint, potentially exposing sensitive information.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-q6fm-p73f-x862

## What is CVE-2026-32268?

CVE-2026-32268 is a high-severity missing authorization vulnerability in craftcms azure-blob, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Azure Blob Storage for Craft CMS plugin provides an Azure Blob Storage integration for Craft CMS. In versions on the 2.x branch prior to 2.1.1, unauthenticated users can view a list of buckets the plugin has access to. The `DefaultController->actionLoadContainerData()` endpoint allows unauthenticated users with a valid CSRF token to view a list of buckets that the plugin is allowed to see. Because Azure can return sensitive data in error messages, additional attack vectors are also exposed. Users should update to version 2.1.1 of the plugin to mitigate the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-32268?

2 open source packages ship an affected version, including craftcms/azure-blob.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/azure-blob` | Packagist | From 2.0.0-beta.1 | 2.1.1 |
| `craftcms/azure-blob` | Packagist | From 2.0.0-beta.1 | 2.1.1 |

## How do I fix CVE-2026-32268?

Upgrade craftcms/azure-blob to 2.1.1 or later.

## Is CVE-2026-32268 being exploited?

There is no known exploitation of CVE-2026-32268 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32268 and fix it if it is affected.

What it is: CVE-2026-32268 is a high-severity missing authorization vulnerability in craftcms azure-blob, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32268 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/azure-blob (Packagist): affected from 2.0.0-beta.1; fixed in 2.1.1
- craftcms/azure-blob (Packagist): affected from 2.0.0-beta.1; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32268/ (Markdown: https://insights.sbomify.com/CVE-2026-32268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32268
- OSV: https://osv.dev/vulnerability/CVE-2026-32268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32268/
Summaries are generated and may contain mistakes; the official description above is the record.
