CVE-2026-32269 Parse Server OAuth2 adapter app ID validation sends wrong token to introspection endpoint
Misconfigured OAuth2 adapter sends wrong token to introspection, potentially allowing unauthorized access or causing login failures.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32269?
CVE-2026-32269 is a medium-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.13 and 8.6.39, the OAuth2 authentication adapter does not correctly validate app IDs when appidField and appIds are configured. During app ID validation, a malformed value is sent to the token introspection endpoint instead of the user's actual access token. Depending on the introspection endpoint's behavior, this could either cause all OAuth2 logins to fail, or allow authentication from disallowed app contexts if the endpoint returns valid-looking data for the malformed request. Deployments using the OAuth2 adapter with appidField and appIds configured are affected. This vulnerability is fixed in 9.6.0-alpha.13 and 8.6.39.
Weakness: CWE-683
Which versions are affected by CVE-2026-32269?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | From 8.0.2 | 8.6.39 |
parse-server npm | From 8.0.2 | 8.6.39 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.13 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.13 |
parse Bitnami | From 8.0.2 | 8.6.39, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-32269?
Upgrade parse-server to a fixed version for your release line: 8.6.39 or 9.6.0-alpha.13.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-32269 being exploited?
There is no known exploitation of CVE-2026-32269 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-32269, GHSA-69xg-f649-w5g2.