CVE-2026-32271 Craft Commerce: SQL Injection can lead to Remote Code Execution via TotalRevenue Widget
Authenticated users can achieve remote code execution via SQL injection in the TotalRevenue widget, allowing arbitrary command execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32271?
CVE-2026-32271 is a high-severity SQL injection vulnerability in craftcms commerce, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft Commerce is an ecommerce platform for Craft CMS. In versions 4.0.0 through 4.10.2 and 5.0.0 through 5.5.4, there is an SQL injection vulnerability in the Commerce TotalRevenue widget which allows any authenticated control panel user to achieve remote code execution through a four-step exploitation chain. The attack exploits unsanitized widget settings interpolated into SQL expressions, combined with PDO's default multi-statement query support, to inject a maliciously serialized PHP object into the queue table. When the queue consumer processes the injected job, the unrestricted unserialize() call in yii2-queue instantiates a GuzzleHttp FileCookieJar gadget chain whose __destruct() method writes a PHP webshell to the server's webroot. The complete chain requires only three HTTP requests, no administrative privileges, and results in arbitrary command execution as the PHP process user, with queue processing triggered via an unauthenticated endpoint. This issue has been fixed in versions 4.10.3 and 5.5.5.
Weakness: CWE-89
Which versions are affected by CVE-2026-32271?
4 open source packages ship an affected version, including craftcms/commerce.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/commerce Packagist | From 4.0.0 | 4.10.3 |
craftcms/commerce Packagist | From 4.0.0 | 4.10.3 |
craftcms/commerce Packagist | From 5.0.0 | 5.5.5 |
craftcms/commerce Packagist | From 5.0.0 | 5.5.5 |
How do I fix CVE-2026-32271?
Upgrade craftcms/commerce to a fixed version for your release line: 4.10.3 or 5.5.5.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-32271 being exploited?
There is no known exploitation of CVE-2026-32271 in the wild and no public exploit code.
Sources
Also known as GHSA-875v-7m49-8x88.