# CVE-2026-32272: Craft Commerce: Blind SQL Injection via hasVariant/hasProduct

> Authenticated users can exploit blind SQL injection in Craft Commerce to extract database contents and escalate privileges to admin.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-r54v-qq87-px5r

## What is CVE-2026-32272?

CVE-2026-32272 is a high-severity SQL injection vulnerability in craftcms commerce, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft Commerce is an ecommerce platform for Craft CMS. In versions 5.0.0 through 5.5.4, an SQL injection vulnerability exists where the ProductQuery::hasVariant and VariantQuery::hasProduct properties bypass the input sanitization blocklist added to ElementIndexesController in a prior security fix (GHSA-2453-mppf-46cj). The blocklist only strips top-level Yii2 Query properties such as where and orderBy, but hasVariant and hasProduct pass through untouched and internally call Craft::configure() on a subquery without sanitization, re-introducing SQL injection. Any authenticated control panel user can exploit this via boolean-based blind SQL injection to extract arbitrary database contents, including security keys that enable forging admin sessions for privilege escalation. This issue has been fixed in version 5.6.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-32272?

2 open source packages ship an affected version, including craftcms/commerce.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.6.0 |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.6.0 |

## How do I fix CVE-2026-32272?

Upgrade craftcms/commerce to 5.6.0 or later.

## Is CVE-2026-32272 being exploited?

There is no known exploitation of CVE-2026-32272 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32272 and fix it if it is affected.

What it is: CVE-2026-32272 is a high-severity SQL injection vulnerability in craftcms commerce, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32272 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.6.0
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32272/ (Markdown: https://insights.sbomify.com/CVE-2026-32272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32272
- OSV: https://osv.dev/vulnerability/CVE-2026-32272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32272/
Summaries are generated and may contain mistakes; the official description above is the record.
